Bug#721594: atd cannot create hardlinks for atjobs to run

dEbian Bugs RC

Package: at
Version: 3.1.13-2
Severity: grave
Tags: upstream
Justification: renders package unusable



-- System Information:
Debian Release: 7.1
APT prefers stable
APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages at depends on:
ii libc6 2.13-38
ii libpam-runtime 1.1.3-7.1
ii libpam0g 1.1.3-7.1
ii lsb-base 4.1+Debian8+deb7u1

Versions of packages at recommends:
ii exim4-daemon-light [mail-transport-agent] 4.80-7

at suggests no packages.
Hmm, that should have been fixed in 3.1.13-1[1] (and also in the version
in Squeeze).

[1] <http://bugs.debian.org/597130>

It also works for me (with protected_hardlinks = 1). Could you please
make sure that
a, you run /usr/sbin/atd, not something in /usr/local,
b, this is actually 3.1.13-2, e.g. submit the output of
$ md5sum /usr/sbin/atd
and
c, please also include the current permissions of
/var/spool/cron/atjobs (ls -ld ...).
The last point shouldn't have an influence as far as I know, but it
never hurts to check.

Ansgar