Bug#488170: inkscape: with libpoppler3 0.8.3-1: crashes when opening PDFs, FTBFS

dEbian Bugs RC

Package: inkscape
Version: 0.46-1+b1
Severity: serious
Tags: patch
Justification: no longer builds from source

Hi,

I noticed that inkscape started crashing with PDFs after the recent
upgrade of libpoppler3; furthermore, it can no longer be built from the
Debian sources.

These are the show-stopping errors when running dpkg-buildpackage:

extension/internal/pdfinput/pdf-parser.cpp:2248: error: no matching function for call to ‘GfxFont::getNextChar(char*&,
int&, CharCode*, Unicode [8], int, int*, double*, double*, double*, double*)’
/usr/include/poppler/GfxFont.h:204: note: candidates are: virtual int GfxFont::getNextChar(char*, int, CharCode*, Unico
de**, int*, double*, double*, double*, double*)
extension/internal/pdfinput/pdf-parser.cpp:2270: warning: deprecated conversion from string constant to ‘char*’
extension/internal/pdfinput/pdf-parser.cpp:2297: error: no matching function for call to ‘GfxFont::getNextChar(char*&,
int&, CharCode*, Unicode [8], int, int*, double*, double*, double*, double*)’
/usr/include/poppler/GfxFont.h:204: note: candidates are: virtual int GfxFont::getNextChar(char*, int, CharCode*, Unico
de**, int*, double*, double*, double*, double*)

I found that this problem is known on Gentoo:
http://bugs.gentoo.org/show_bug.cgi?id=224883

They have a patch:
http://sources.gentoo.org/viewcvs.py/gentoo-x86/media-gfx/inkscape/files/inkscape-0.46-poppler-0.8.3.patch?view=markup

I can build the Debian package after applying this patch and PDF import
works again.

Thank you for your time and for your work on the inkscape package.

- System Information:
Debian Release: lenny/sid
APT prefers unstable
APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.25-flo (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages inkscape depends on:
ii libatk1.0-0 1.22.0-1 The ATK accessibility toolkit
ii libc6 2.7-12 GNU C Library: Shared libraries
ii libcairo2 1.6.4-6 The Cairo 2D vector graphics libra
ii libcairomm-1.0-1 1.6.0-1 C++ wrappers for Cairo (shared lib
ii libfontconfig1 2.6.0-1 generic font configuration library
ii libfreetype6 2.3.6-1 FreeType 2 font engine, shared lib
ii libgc1c2 1:6.8-1.1 conservative garbage collector for
ii libgcc1 1:4.3.1-2 GCC support library
ii libgconf2-4 2.22.0-1 GNOME configuration database syste
ii libglib2.0-0 2.16.3-2 The GLib library of C routines
ii libglibmm-2.4-1c2a 2.16.3-1 C++ wrapper for the GLib toolkit (
ii libgnomevfs2-0 1:2.22.0-4 GNOME Virtual File System (runtime
ii libgtk2.0-0 2.12.10-2 The GTK+ graphical user interface
ii libgtkmm-2.4-1c2a 1:2.12.7-1 C++ wrappers for GTK+ 2.4 (shared
ii libgtkspell0 2.0.13-1 a spell-checking addon for GTK's T
ii liblcms1 1.16-10 Color management library
ii libmagick++10 7:6.3.7.9.dfsg1-2+b2 C++ API to the ImageMagick library
ii libmagick10 7:6.3.7.9.dfsg1-2+b2 image manipulation library
ii libpango1.0-0 1.20.3-2 Layout and rendering of internatio
ii libpng12-0 1.2.27-1 PNG library - runtime
ii libpoppler-glib3 0.8.3-1 PDF rendering library (GLib-based
ii libpoppler3 0.8.3-1 PDF rendering library
ii libpopt0 1.14-4 lib for parsing cmdline parameters
ii libsigc++-2.0-0c2a 2.0.18-2 type-safe Signal Framework for C++
ii libssl0.9.8 0.9.8g-10.1 SSL shared libraries
ii libstdc++6 4.3.1-2 The GNU Standard C++ Library v3
ii libwpd8c2a 0.8.14-1 Library for handling WordPerfect d
ii libwpg-0.1-1 0.1.2-1 WordPerfect graphics import/conver
ii libx11-6 2:1.1.4-2 X11 client-side library
ii libxft2 2.1.12-3 FreeType-based font drawing librar
ii libxml2 2.6.32.dfsg-2 GNOME XML library
ii libxslt1.1 1.1.24-1 XSLT processing library - runtime
ii zlib1g 1:1.2.3.3.dfsg-12 compression library - runtime

Versions of packages inkscape recommends:
ii imagemagick 7:6.3.7.9.dfsg1-2+b2 image manipulation programs
ii libwmf-bin 0.2.8.4-6 Windows metafile conversion tools
ii perlmagick 7:6.3.7.9.dfsg1-2+b2 Perl interface to the libMagick gr
ii pstoedit 3.45-4 PostScript and PDF files to editab