Bug#423148: file conflicts between packages

dEbian Bugs RC

Package: postgresql-filedump-8.1, postgresql-filedump-8.2
Severity: serious
Usertags: qa-file-conflict
Justification: Policy violation, see section 7.2

hi,

both postgresql-filedump-8.1 and postgresql-filedump-8.2 ship
`/usr/bin/pg_filedump' but do neither conflict nor add a diversion, thus fail
to be installed in the same environment:

Unpacking postgresql-filedump-8.2 (from .../postgresql-filedump-8.2_8.2-2_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/postgresql-filedump-8.2_8.2-2_amd64.deb (--unpack):
trying to overwrite `/usr/bin/pg_filedump', which is also in package postgresql-filedump-8.1
Errors were encountered while processing:
/var/cache/apt/archives/postgresql-filedump-8.2_8.2-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

bye,
- michael