Bug#325962: depends on a FLAC library no longer available in unstable

dEbian Bugs RC

Package: pyflac
Severity: serious

Hello,

If you're receiving this message, you have a package that depends on one
of the FLAC libraries (libFLAC, libFLAC++, libOggFLAC, libOggFLAC++.)
Once again, the SONAME of the libraries has increased due to an API
transition and you must rebuild your packages.

Please briefly review the upstream API changelog at:

http://flac.sourceforge.net/changelog.html

to check if any of the API changes affect your FLAC-depending package.
In most cases, a simple rebuild will be sufficient to transition. If you
like, you can version the libflac-dev, libflac++-dev, liboggflac-dev,
or liboggflac++-dev build-dependency to (>= 1.1.2-1) to ensure that your
package is autobuilt against the new versions of the libraries.

Please contact me if you have any questions regarding the transition.
Sorry for the inconvenience, and thank you.
and subject line Bug#325962: fixed in pyflac 0.0.4-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere. Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: from smtp103.sbc.mail.mud.yahoo.com [68.142.198.202]
by spohr.debian.org with smtp (Exim 3.36 1 (Debian))

Received: from unknown (HELO triplehelix.org) ([email protected]@68.126.216.211 with login)
Received: by triplehelix.org (Postfix, from userid 1000)
Subject: depends on a FLAC library no longer available in unstable
To: [email protected]
Delivered-To: [email protected]
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02
(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level:
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_PACKAGE,
RCVD_IN_DSBL autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: pyflac
Severity: serious

Hello,

If you're receiving this message, you have a package that depends on one
of the FLAC libraries (libFLAC, libFLAC++, libOggFLAC, libOggFLAC++.)
Once again, the SONAME of the libraries has increased due to an API
transition and you must rebuild your packages.

Please briefly review the upstream API changelog at:

http://flac.sourceforge.net/changelog.html

to check if any of the API changes affect your FLAC-depending package.
In most cases, a simple rebuild will be sufficient to transition. If you
like, you can version the libflac-dev, libflac++-dev, liboggflac-dev,
or liboggflac++-dev build-dependency to (>= 1.1.2-1) to ensure that your
package is autobuilt against the new versions of the libraries.

Please contact me if you have any questions regarding the transition.
Sorry for the inconvenience, and thank you.

--
Joshua Kwan

---------------------------------------
Received: from katie by spohr.debian.org with local (Exim 3.36 1 (Debian))
To: [email protected]
X-Katie: $Revision: 1.56 $
Subject: Bug#325962: fixed in pyflac 0.0.4-1
Delivered-To: [email protected]
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02
(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Level:
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER
autolearn=no version=2.60-bugs.debian.org_2005_01_02

Source: pyflac
Source-Version: 0.0.4-1

We believe that the bug you reported is fixed in the latest version of
pyflac, which is due to be installed in the Debian FTP archive:

pyflac_0.0.4-1.diff.gz
to pool/main/p/pyflac/pyflac_0.0.4-1.diff.gz
pyflac_0.0.4-1.dsc
to pool/main/p/pyflac/pyflac_0.0.4-1.dsc
pyflac_0.0.4.orig.tar.gz
to pool/main/p/pyflac/pyflac_0.0.4.orig.tar.gz
python-flac_0.0.4-1_i386.deb
to pool/main/p/pyflac/python-flac_0.0.4-1_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to [email protected],
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing [email protected])


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Source: pyflac
Binary: python-flac
Architecture: source i386
Version: 0.0.4-1
Distribution: unstable
Urgency: low
Description:
python-flac - Free Lossless Audio Codec [Python bindings]
Closes: 325962
Changes:
pyflac (0.0.4-1) unstable; urgency=low
.
* New upstream version.
* Build-Depend on >= 1.1.2-1 to ensure we use libflac7. (Closes: #325962)
* Build-Depend on SWIG again.
* Standards-Version 3.6.2.
Files:
173f1a0f430209d48d4680bea2bca10a 618 python optional pyflac_0.0.4-1.dsc
b4d864fdd866b3a2440ed011ee66910a 32875 python optional pyflac_0.0.4.orig.tar.gz
35ee7d27a63458bd05b4aaa9bafd709d 1537 python optional pyflac_0.0.4-1.diff.gz
358aae09796414431b66d5f6abb62e50 105272 python optional python-flac_0.0.4-1_i386.deb